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Chapter I. Getting started
1. Download and install
The latest version of eParapher can be downloaded from the eParapher Downloads page, at this address :
http://www.eparapher.com/download/index.html [http://www.eparapher.com/download/index.html] .
System requirements
• Mac OS X 10.4 or later, Windows, Linux
• Java Runtime Environment [http://www.java.com/] 5 or later
Installing on Mac OS X
Follow this installation process:
• Step 1: Double-click the downloaded package to mount the Apache Directory Studio DMG.
• Step 2: Drag and drop the Apache Directory Studio application to your Applications folder.
Installing on Linux
Follow this installation process:
• Step 1: Uncompress the Tar Gzip archive ('tar xzf eParapher-0.1.0-SNAPSHOT-linux-i386.tar.gz' for
the i386 Linux version).
• Step 2: Move the eParapher folder to the location of your choice.
Installing on Windows
Follow this installation process:
• Unzip the Zip archive.
• Run the installer and follow install instructions.
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Chapter II. Tasks
1. Running eParapher
Mac OS X
If you followed the instructions on the "Download and install" page, simply double-click the eParapher
application located in your Applications folder.
Linux
After installing eParapher in a directory, you can start it by running the eParapher executable included
with the release.
Windows
If you followed the instructions on the "Download and install" page, simply click on the eParapher
executable in the eParapher folder located in the All programs item of the Start menu.

2. Updating eParapher
To check to see whether there are updates for features of Apache Directory Studio (requires Internet
access):
1. Click Help > Software Updates >
Search for updates... . This will contact eParapher Web site
to discover what versions of those features are available. The potential upgrades are presented in on the
next page.
2. Select the feature versions that you wish to upgrade, and click Next .
3. Carefully review the license agreements for the upgraded features. If the terms of all these licenses are
acceptable, check "I accept the terms in the license agreements." Do not proceed to download the features
if the license terms are not acceptable.
4. Feature versions can be digitally signed by the company that provides them. This allows you to verify
more easily that the features and plug-ins that are about to be downloaded and installed are coming from
a trusted supplier.
Click Install to allow the downloading and installing to proceed.
5. Once all the features and plug-ins have been downloaded successfully and their files installed into the
product on the local computer, a new configuration that incorporates these features and plug-ins will be
formulated. Click Yes when asked to exit and restart the Workbench for the changes to take effect.

2.1. Inspecting the current configuration
The Help > About ePArapher dialog shows most of the important information about the features and
plug-in configured in the product. To find out further detailed information about the current configuration:
1. Open the update configuration manager by clicking Help > Software Updates >
Configuration . This opens the Product Configuration dialog.
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2. In the Product Configuration dialog expand the root node (current configuration). The first tier of items
are locations on the local computer where the files for features and plug-ins are stored. For a typical
product, all features are installed in a single directory sub-tree. However, a feature that is installed as an
extension of another product are usually located in a separate directory sub-tree.
3. Expand the location to see the feature versions installed there.
4. The nesting of the features indicates which child features are included in a given parent feature. Nested
features act as a unit.
5. Select a feature version and click Show Properties to open the Properties dialog which presents more
detailed information about the selected feature.
6. Click Show Disabled Features filter on the toolbar of the Product Configuration dialog. Any feature
versions that are disabled are now shown (you might not have any). Disabled feature versions are ones that
are installed on the local computer but excluded from the current configuration. At most one version of
any given feature can be present in a given configuration; usually the ones with the lower version numbers
will be in a disabled state.
7. In the Properties dialog of a feature, click Status to find out whether the selected feature is configured
exactly as packaged. The status will show when a feature's plug-ins are present at different versions, or
disabled due to missing prerequisite plug-ins that are expected to be supplied by some other feature.

2.2. Enabling, disabling and uninstalling features
You can browse and manage your configuration from the Product Configuration dialog . Open the
Product Configuration dialog by clicking Help > Software Updates >

Manage Configuration .

1. Disabling a feature : select the feature and click Disable in the right pane of the dialog. This option
is available only when the feature is currently enabled, and the feature is either an optional feature or a
root feature (not included by other features).
2. Enabling a feature : First, ensure Show Disabled Features is turned on in the tool bar. Then, select a
disabled optional or root feature and click Enable in the right pane of the dialog.
3. Uninstalling a feature : features that you have installed using the update manager can be uninstalled,
provided they are already disabled, or that they are optional or root features. If the feature is disabled,
make sure Show Disabled Features is turned on in the tool bar. Select the feature and click Uninstall
in the right page of the dialog.

3. Reporting a bug
You can reach our issue tracking software called Trac using this address : http://trac.eparapher.com/cgibin/trac.cgi/newticket [http://trac.eparapher.com/cgi-bin/trac.cgi/newticket]
To report a bug:
1. Enter a short summary.
2. Select the type defect.
3. Fill in the full description with all the details you have.
4. Click the Submit ticket button to create the new issue.
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Chapter III. Configuration
1. Eclipse Preferences
The Preferences dialog is the dialog used to set user preferences. The Preferences dialog pages can be
searched using the filter function. To filter by matching the page title, simply type the name of the page
you are seeking and the available pages will be presented below. The filter also searches on keywords such
as appearance and java. The history controls allow you to navigate through previously viewed pages. To
step back or forward several pages at a time, click the drop down arrow and a list of the most recently
viewed preference pages will appear.
The Preferences dialog can be found from the main workbench Window menu under Window >
Preferences . Preference pages contributed by plug-ins will be found in this dialog.

1.1. Help
On the Help preferences page, you can indicate how to display help information.
Option

Description

Default

Use external browsers

If embedded web browser is supported on Off
your system, help window uses an embedded
help browser to display help contents, whenever
possible, and this option is available. Select it, to
force help to use external browsers. Use "Web
Browser" preference page to select browser to use.

Open window context This option allows you to determine whether the in a dynamic help view
help
window context help will be opened in a dynamic
help view or in an infopop.
Open dialog context help This option allows you to determine whether the in dialog tray
dialog context help will be opened in a dynamic help
section of help view or in an infopop.
Help view
open mode
Search

document This option allows you to determine whether the Open in place
documents selected in the help view will be opened
in place or in the editor area.
Determines whether potential hits should be Show all potential hits
shown while searching. Showing potential hits will (faster)
increase search performance, at the cost of potential
loss of accuracy.

Here is what the Help preferences page looks like:
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1.1.1. Help Server
Help system includes an internal server that serves help contents to the browser. Use the Help > Help
Server preference page to change the interface and port that the servers uses. You should only change
these settings if you experience problems and cannot view help with the default preferences.
Option

Description

Default

Host

Name or address of a local IP interface to be used blank
by the server.

Port

IP port for server to listen on. If no port is specified blank
for the value, a port will be assigned by the operating
system.

Here is what the Help preferences page looks like:

1.2. Install/Update
The following preferences can be changed on the Install/Update page:
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Option

Description

Default

Maximum number of Maximum number of configurations you want 100
'History' configurations maintained in the configuration history. These
configurations are maintained to allow you to revert
to a previous configuration of installed feature
versions.
Check digital signatures This option will check for digital signatures of On
of downloaded archives downloaded archives.
Valid updates

Assuming that feature versions use the form equivalent
'major.minor.service', you can select what update
level you want to choose from:
• equivalent : Only service updates will be
displayed.
• compatible : Service updates and minor updates
will be displayed.

Update Policy

The update policy URL that controls the redirection No policy
of update sites within an organization.

Proxy settings

Allows connection to the remote server from No proxy
behind the firewall. When enabled, proxy host
address (required) and port number (optional) can
be specified.

Here is what the Install/Update preferences page looks like:
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1.2.1. Automatic Updates
The following preferences can be changed on the Automatic Updates page:
Option

Description

Default

Automatically find new When selected, Update manager will automatically Off
updates and notify me
search for update, as defined by the update schedule
Update Schedule

Look for updates on each startup, or once a day or on startup
some day a week, at a predefined time.

Download Options

This option allows you to choose between having on startup
Eclipse search for updates and notifying you of
them once they are available or having Eclipse
automatically download new updates and asking
you to install them.

Here is what the Automatic Updates preferences page looks like:

1.3. Installed JREs
The following preferences can be changed on the Installed JREs page:
This page allows a new default JRE to be selected as well as adding new JRE installations.
Option

Description

Default

Installed JREs

The current listing of installed JREs, allowing you
to select the one to act as the workspace default

Add...

Adds a new JRE definition to the workbench. In the
resulting dialog, specify the following:
• JRE type: (select a VM type from the drop-down
list)
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Option

Description

Default

• JRE name: Type a name for this JRE definition
• JRE home directory: Type or browse to select the
root directory for this JRE installation
• Default VM arguments: Type the VM arguments
to be used on the command line each time this
JRE is used to run or debug a program
• Use the JRE system libraries list to manage the
libraries associated with the JRE. These are the
libraries that appear on the build path and default
runtime boot path.
• You can add, remove, and re-order the libraries
• You can specify a source attachment and
javadoc location for each library. Multi-select
to modify more than one library at once.
• Use the Restore Default button to revert to the
JRE's default libraries
Edit...

Allows you to edit the selected JRE.

Copy...

Creates a copy of the selected JRE with the same
attributes and a new name.

Remove

Removes the selected JRE from the workbench.

Search...

Automatically searches for JREs installed in the
local file system and creates corresponding JRE
definitions in the workspace.

Here is what the Installed JREs preferences page looks like:
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1.4. Network Connections
The following preferences can be changed on the Network Connections page:
Option

Description

Default

Direct connection to the Enable this option to have all connections to remote Enabled
Internet
systems happen directly without involving a proxy
server.
Manual
configuration

proxy Use this option if connections to remote systems Disabled
should happen through a proxy server.

HTTP Proxy

Use this option to specify the server and port that is
to be used when making HTTP connections. If the
port field is empty, the default port of 80 is used. If
the "Use this proxy server for SSL" is checked, the
HTTP proxy server is used for SSL connections as
well.

SSL Proxy

Use this option to specify the server and port that
is to be used when making SSL connections. If the
port field is empty, the default port of 443 is used.

SOCKS Proxy

Use this option to specify the server and port that
is to be used when making SOCKS connections. If
the port field is empty, the default port of 1080 is
used. [1]

Non-proxied Hosts (No Use this table to specify, either by name or pattern,
Proxy for)
which hosts should not use any proxy but instead
should always be connected to directly.
Proxy Authentication

Enable this option to specify a user name and Disabled
password that is to be used when connecting to the
proxy server.

Here is what the Network Connections preferences page looks like:
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1. The SOCKS proxy support in Java 1.4 had certain limitations. Due to these limitations, the setting of
the SOCKS system properties is not performed when a 1.4 VM is used. The SOCKS proxy may still be
used by some tooling when running on a 1.4 VM (e.g. CVS). However, users should use a 1.5 (or 5.0)
VM if they require full SOCKS proxy support.

1.5. Text Editors
The following preferences can be changed on the Text Editors page.
Option

Description

Default

Displayed tab width

This option allows you to set the displayed tab width 4
for the text editor.

Undo history size

This option allows you to undo the history size for 25
the text editor.

Highlight current line

This option controls whether or the current line is On
highlighted or not.

Show print margin

This option controls whether the print margin is Off
visible or not.

Show line numbers

This option controls whether or not line numbers are Off
shown on the left side of the text editor.

Show range indicators

This option controls whether or not range indicators On
are shown in the text editor.

Support hyperlink style This option controls whether or not hyperlink style On
navigation
navigation is supported.
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Option

Description

Default

Hyperlink
style This option sets the hyperlink style navigation key Ctrl
navigation key modifier modifier.
Disable overwrite typing This option controls whether the overwrite typing Off
mode
mode is enabled or disabled.
Appearance
options

color This option controls various appearance colors.

-

Here is what the Help preferences page looks like:

1.5.1. Accessibility
The following preferences can be changed on the Text Editors > Accessibility page.
Option

Description

Default

Use custom caret

This option replaces the original caret with a custom On
caret and shows a different caret for Overwrite and
Insert mode.

Enable thick caret

This option replaces the original caret with a more On
visible, thicker caret.
Off
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Option

Description

Default

Use characters to show Quick Diff shows the changes in a vertical ruler
changes on line number using colors. Color blind persons can enable this
bar
option to show the differences with different
characters in the line number ruler.
Here is what the Accesibility preferences page looks like:

1.5.2. Annotations
The following preferences can be changed on the Text Editors > Annotations preference page.
Option

Description

Show in Text as

This option controls whether the selected annotation type is shown in
the text. The corresponding text will be underlined with squiggles or
highlighted.

Show in Overview ruler

This option controls whether the overview ruler on the right side of
the text editor is shown.

Show in Vertical ruler

This option controls whether the selected annotation type is shown in
the vertical ruler.

Color

This option controls the color for the selected annotation type.

Here is what the Annotations preferences page looks like:
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1.5.3. Linked Mode
Here is what the Linked Mode preferences page looks like:

1.5.4. Quick Diff
The following preferences can be changed on the Text Editors > Quick Diff preference page.
Option

Description

Enable quick diff

This option will enable or disable the quick diff On
option.

Show differences
overview ruler

Default

in This option will show differences in the overview Off
ruler.

Colors - Changes

This option controls the color of changes.

-

Colors - Additions

This option controls the color of additions.

-

13

Configuration

Option

Description

Default

Colors - Deletions

This option controls the color of deletions.

-

Use this reference source This option sets which reference to use as the base Version on Disk
for generating quick diff comparisons. Options are:
• Version on Disk: Current file is compared against
the last saved version on disk.
• Latest CVS Revision: Current file is compared
against the latest CVS revision for the file.
Here is what the Quick Diff preferences page looks like:

1.5.5. Spelling
The following preferences can be changed on the Text Editors > Spelling preference page.
Option

Description

Default

Enable spell checking

This option enables spell checking.

Off

Ignore words with digits This option ignores words with digits when Off
performing spell checking.
Ignore mixed case words This option ignores mixed case words when Off
performing spell checking.
Ignore
capitalization

sentence This option ignores sentence capitalization when Off
performing spell checking.

Ignore upper case words This option ignores upper case words when Off
performing spell checking.
Ignore internet addresses This option ignores internet addresses when Off
performing spell checking.
Platform dictionary

This option selects a platform dictionary to use.

User defined dictionary

This option selects a User defined dictionary to use. -
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Option

Description

Default

Maximum number of This option limits the possible corrections displayed 20
correction proposals
to the given value.
Make
dictionary This option allows content assist to use the 20
available to content assist dictionary when constructing its choices.
Here is what the Spelling preferences page looks like:

2. eParapher Preferences
The Preferences dialog is the dialog used to set user preferences. The Preferences dialog pages can be
searched using the filter function. To filter by matching the page title, simply type the name of the page
you are seeking and the available pages will be presented below. The filter also searches on keywords such
as appearance and java. The history controls allow you to navigate through previously viewed pages. To
step back or forward several pages at a time, click the drop down arrow and a list of the most recently
viewed preference pages will appear.
The Preferences dialog can be found from the main workbench Window menu under Window >
Preferences . Preference pages contributed by plug-ins will be found in this dialog.

2.1. Keystore settings
TODO

2.2. Password Policy for Keystore
TODO
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2.3. Open Office Configuration
OpenOffice help eParapher to convert your documents to PDF or PDF/A. TODO

2.4. Digital signature default settings
Configure your digital signature default parameters here. TODO
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Chapter IV. What's new
What's new in 0.0.2
Coming soon
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Chapter V. Release notes
Apache Directory Studio 1.3.0 RC1 - (2008,
October 13th)
Improvement
• [DIRSTUDIO-255] - Run in background should be configurable so one could set it to true by default
Task
• [DIRSTUDIO-376] - Move to the latest Eclipse 3.4 dependencies
• [DIRSTUDIO-375] - Move each plugin IDs in a plugin.properties file

Apache Directory Studio 1.2.0 - (2008, august
18th)
Bug
• [DIRSTUDIO-347] - Keybinding conflict for CTRL+Q
• [DIRSTUDIO-330] - CoreException raised in editor when opening a *.txt file
• [DIRSTUDIO-325] - Keybinding conflicts occurred. They may interfere with normal accelerator
operation.
• [DIRSTUDIO-342] - Relax the parser for the *.schema files
• [DIRSTUDIO-266] - OpenLDAP schema files parser fails when DESC contains an empty string ''
Improvement
• [DIRSTUDIO-337] - Add Save and Print actions in the toolbar of the RCP application
• [DIRSTUDIO-295] - Add a console for errors
New Feature
• [DIRSTUDIO-321] - Need to be able to set SOCKS proxy in the RCP version
Task
• [DIRSTUDIO-339] - Add the 'org.eclipse.ui.carbon' Eclipse plugin to the Mac OS X distribution
• [DIRSTUDIO-338] - Update Eclipse dependencies to the latest Eclipse version (3.3.2)

Apache Directory Studio 1.1.0 - (2008, march
31st)
Task
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Release notes

• [DIRSTUDIO-280] - Remove remaining unwanted contributions from Eclipse

Apache Directory Studio 1.0.0 (2007,
september 3rd) : initial release
Includes :
• Apache Directory Studio Apache DS Configuration 1.0.0
• Apache Directory Studio LDAP Browser 1.0.0
• Apache Directory Studio LDIF Editor 1.0.0
• Apache Directory Studio RCP 1.0.0
• Apache Directory Studio Schema Editor 1.0.0
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